[Production] Equifax

Incident Report for Checkboard

Resolved

This incident has been resolved now.
Posted Mar 26, 2025 - 09:18 UTC

Investigating

We are currently investigating this issue.
Posted Mar 26, 2025 - 06:28 UTC
This incident affected: Core Services.