[Production] Equifax
Incident Report for Checkboard
Resolved
No impact
Posted Nov 25, 2024 - 17:38 UTC
Investigating
We are currently investigating this issue.
Posted Nov 25, 2024 - 10:35 UTC
This incident affected: Core Services.